vLLMPYSEC-2026-4352
vLLM: resource exhaustion
Fix: upgrade to 0.25.0 or later
vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL processors globally set Image.MAX_IMAGE_PIXELS to None. Attackers can submit a pathological decompression-bomb image to /v1/chat/completions to OOM-kill the worker and deny service to co-tenants.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| vllm PyPI | >= 0.10.2, < 0.25.0 | 0.25.0 |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Severity from
- the CVSS score
- Also known as
- CVE-2026-116177, GHSA-mm38-5g96-7j6x