vLLMPYSEC-2026-4350
vLLM: denial of service
Fix: upgrade to 0.24.0 or later
vLLM from 0.22.0 before 0.24.0 contains a denial of service vulnerability that allows remote attackers to terminate EngineCore by bypassing logprob_token_ids limits in the Rust gRPC frontend. Attackers can send Generate or GenerateStream requests with output_logprobs enabled and more than 128 output_candidates.token_ids, triggering a fatal sampler exception that crashes the engine.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| vllm PyPI | >= 0.22.0, < 0.24.0 | 0.24.0 |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Severity from
- the CVSS score
- Also known as
- CVE-2026-116173, GHSA-6pgw-f3pv-4h8q