vLLMPYSEC-2026-4351
vLLM: server-side request forgery
Fix: upgrade to 0.24.0 or later
vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| vllm PyPI | >= 0.9.2, < 0.24.0 | 0.24.0 |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
- Severity from
- the CVSS score
- Also known as
- CVE-2026-116176, GHSA-vfp2-c8pq-v6h6