GitLabCVE-2026-14288
GitLab: improper access control
Fix: upgrade to 19.3.6 or later (3 fixed versions below)
GitLab has remediated an issue in GitLab EE affecting all versions from 17.4 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated to bypass a required merge request approval policy on a protected branch due to improper access control during approval rule synchronization.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| GitLab Product | >= 17.4, < 19.3.6 | 19.3.6 |
| >= 19.4, < 19.4.3 | 19.4.3 | |
| >= 19.5, < 19.5.1 | 19.5.1 |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Severity from
- the vendor (its own CVE record or advisory)
- Weakness
- CWE-706