GitLabCVE-2026-12664
GitLab: improper authorization
Fix: upgrade to 19.3.6 or later (3 fixed versions below)
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an authenticated user with a read_api-scoped token to retrieve a project's incoming email address and create work items, bypassing the token's restrictions, due to insufficient scope enforcement on a GraphQL field.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| GitLab Product | >= 18.2, < 19.3.6 | 19.3.6 |
| >= 19.4, < 19.4.3 | 19.4.3 | |
| >= 19.5, < 19.5.1 | 19.5.1 |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- Severity from
- the vendor (its own CVE record or advisory)
- Weakness
- CWE-863