GitHubGHSA-rrp4-2xx3-mv29
Improper Input Validation of `-database` Parameter
Fix: upgrade to 1.1.3 or later
Gh-ost version <= 1.1.2 allows users to inject DSN strings via the -database parameter.
This is a low severity vulnerability as the attacker must have access to the target host or trick an administrator into executing a malicious gh-ost command on a host running gh-ost, plus network access from host running gh-ost to the attack's malicious MySQL server.
Impact
This issue may lead to arbitrary local file read.
Patches
Fixed in 1.1.3+.
Workarounds
None
References
- https://advisory.dw1.io/51
For more information
If you have any questions or comments about this advisory:
- Open an issue in [github/gh-ost](http://github.com/github/gh-ost)
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| gh-ost Go | < 1.1.3 | 1.1.3 |
Details and references
More GitHub advisories
All GitHubCVE-2023-4759Jul 25, 2024Arbitrary File Overwrite in CodeQL versions less than 2.18.1HighFixed in 2.18.1CVE-2024-25129Feb 22, 2024Limited data exfiltration in CodeQL CLILow2.7Fixed in 2.16.3CVE-2021-32638May 25, 2021### Impact The CodeQL runner toolCodeQL runner: Command-line options that make GitHub access tokens visible to other processes are now deprecatedMedium4.4Fixed in codeql-bundle-20210304CVE-2020-5216Jan 22, 2020Limited header injection when using dynamic overrides with user inputMediumFixed in ~3.9CVE-2020-5217Jan 22, 2020Directive injection when using dynamic overrides with user inputMediumFixed in ~3.8CVE-2019-16765Nov 22, 2019Arbitrary code execution when opening a malicious workspaceHighFixed in 1.0.1