Qt Group PlcCVE-2026-95620
qt: use after free
Fix: upgrade to 6.11.3 or later
A use-after-free vulnerability in the Qt QNetworkAccessManager HTTP/2 client support of the Qt Network module allows a malicious or compromised HTTP/2 server to cause the client application to crash, affecting availability.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| qt Product | >= 6.9.0, < 6.11.3 | 6.11.3 |
Details and references
- CVSS 4.0
- CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:N/R:U/V:X/RE:L/U:Green
- Severity from
- the vendor (its own CVE record or advisory)
- Weakness
- CWE-416