HashiCorpCVE-2026-110720
HashiCorp Tooling: improper authorization
Fix: upgrade to 2.0.4 or later
Consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL binding rules that may allow an attacker to obtain elevated Consul privileges. This vulnerability (CVE-2026-110720) is fixed in consul-k8s 2.1.0 and 1.8.18.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| Tooling Product | >= 0.42.0, < 2.0.4 | 2.0.4 |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Severity from
- the vendor (its own CVE record or advisory)
- Weakness
- CWE-863