Apache Software FoundationCVE-2026-108780
Apache Kylin: improper input validation
No fix yet
Potential JDBC source configuration validation vulnerability in Apache Kylin. The impact is minor, unless the kylin backend services are open to public network.
This issue affects Apache Kylin: from 4.0.0 through 5.0.4.
Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Affected versions
| Package | Affected | Fixed in |
|---|---|---|
| Apache Kylin Product | >= 4.0.0, <= 5.0.4 | No fix yet |
Details and references
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Severity from
- CISA (its enrichment of the CVE record)
- Weakness
- CWE-20